Genome Analysis Toolkit

Variant Discovery in High-Throughput Sequencing Data

GATK process banner

Need Help?

Search our documentation

Community Forum

Hi, How can we help?

Developed in the Data Sciences Platform at the Broad Institute, the toolkit offers a wide variety of tools with a primary focus on variant discovery and genotyping. Its powerful processing engine and high-performance computing features make it capable of taking on projects of any size. Learn more

Error: Unable to load libgkl_compression.so from native/libgkl_compression.so (No space left on device)

0

5 comments

  • Avatar
    Genevieve Brandt

    Hello Alex Sanchez, is there room on your machine where you are running this command?

    0
    Comment actions Permalink
  • Avatar
    Alex Sanchez

    Hello, Thanks for your answer. I usually submit this job to a Load Sharing Facility platform using the command bsub. I have 2TB storage space in this platform and I am only using 25% of it, so far other jobs such as alignment using bwa algorithm and marking duplicates with picard worked well. I am also reaching to my IT department so they can let me know if there is any space issues but as far as I know, in the past, other jobs run well.

    0
    Comment actions Permalink
  • Avatar
    Genevieve Brandt

    Alex Sanchez try using the GATK wrapper script to submit your command, there can be weird errors when using the jar file. [More info here]

    Also, you may want to specify a temp directory with the option --tmp-dir

    0
    Comment actions Permalink
  • Avatar
    Alex Sanchez

    Hello, thanks for your response. The problem was solved by uninstalling and older version of gatk and also running GATK wrapper script. But now I am wondering if gatk also uses samtools? cause now I have another error when trying to run the pipeline:

    htsjdk.samtools.SAMException: Sequence name '' doesn't match regex: '[0-9A-Za-z!#$%&+./:;?@^_|~-][0-9A-Za-z!#$%&*+./:;=?@^_|~-]*'

    This may be related to samtools tho, but any feedback is appreciated. Thanks!

    Alex

     

    gatk --java-options "-Xmx10g" BaseRecalibrator -I T_HG2.mkdup.bam -R ~/reference_genome/hg38/GRCh38_full_analysis_set_plus_decoy_hla.fa --known-sites ~/recalibration/dbSNP154v2/sorted.dbSNP154.vcf.gz -O T_HG2.recal_data.grp

    Using GATK jar /nethome/axs2785/miniconda3/envs/align/share/gatk4-4.1.8.1-0/gatk-package-4.1.8.1-local.jar

    Running:

        java -Dsamjdk.use_async_io_read_samtools=false -Dsamjdk.use_async_io_write_samtools=true -Dsamjdk.use_async_io_write_tribble=false -Dsamjdk.compression_level=2 -Xmx10g -jar /nethome/axs2785/miniconda3/envs/align/share/gatk4-4.1.8.1-0/gatk-package-4.1.8.1-local.jar BaseRecalibrator -I T_HG2.mkdup.bam -R /nethome/axs2785/reference_genome/hg38/GRCh38_full_analysis_set_plus_decoy_hla.fa --known-sites /nethome/axs2785/recalibration/dbSNP154v2/sorted.dbSNP154.vcf.gz -O T_HG2.recal_data.grp

    Picked up _JAVA_OPTIONS: -Xmx512 -Xmx10g

    13:08:53.832 INFO  NativeLibraryLoader - Loading libgkl_compression.so from jar:file:/nethome/axs2785/miniconda3/envs/align/share/gatk4-4.1.8.1-0/gatk-package-4.1.8.1-local.jar!/com/intel/gkl/native/libgkl_compression.so

    Oct 08, 2020 1:08:54 PM shaded.cloud_nio.com.google.auth.oauth2.ComputeEngineCredentials runningOnComputeEngine

    INFO: Failed to detect whether we are running on Google Compute Engine.

    13:08:54.017 INFO  BaseRecalibrator - ------------------------------------------------------------

    13:08:54.017 INFO  BaseRecalibrator - The Genome Analysis Toolkit (GATK) v4.1.8.1

    13:08:54.017 INFO  BaseRecalibrator - For support and documentation go to https://software.broadinstitute.org/gatk/

    13:08:54.018 INFO  BaseRecalibrator - Executing as axs2785@login3 on Linux v2.6.32-431.el6.x86_64 amd64

    13:08:54.018 INFO  BaseRecalibrator - Java runtime: Java HotSpot(TM) 64-Bit Server VM v1.8.0_60-b27

    13:08:54.018 INFO  BaseRecalibrator - Start Date/Time: October 8, 2020 1:08:53 PM EDT

    13:08:54.018 INFO  BaseRecalibrator - ------------------------------------------------------------

    13:08:54.018 INFO  BaseRecalibrator - ------------------------------------------------------------

    13:08:54.018 INFO  BaseRecalibrator - HTSJDK Version: 2.23.0

    13:08:54.018 INFO  BaseRecalibrator - Picard Version: 2.22.8

    13:08:54.018 INFO  BaseRecalibrator - HTSJDK Defaults.COMPRESSION_LEVEL : 2

    13:08:54.019 INFO  BaseRecalibrator - HTSJDK Defaults.USE_ASYNC_IO_READ_FOR_SAMTOOLS : false

    13:08:54.019 INFO  BaseRecalibrator - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_SAMTOOLS : true

    13:08:54.019 INFO  BaseRecalibrator - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_TRIBBLE : false

    13:08:54.019 INFO  BaseRecalibrator - Deflater: IntelDeflater

    13:08:54.019 INFO  BaseRecalibrator - Inflater: IntelInflater

    13:08:54.019 INFO  BaseRecalibrator - GCS max retries/reopens: 20

    13:08:54.019 INFO  BaseRecalibrator - Requester pays: disabled

    13:08:54.019 INFO  BaseRecalibrator - Initializing engine

    13:08:54.608 INFO  FeatureManager - Using codec VCFCodec to read file file:///nethome/axs2785/recalibration/dbSNP154v2/sorted.dbSNP154.vcf.gz

    13:08:54.660 INFO  BaseRecalibrator - Shutting down engine

    [October 8, 2020 1:08:54 PM EDT] org.broadinstitute.hellbender.tools.walkers.bqsr.BaseRecalibrator done. Elapsed time: 0.01 minutes.

    Runtime.totalMemory()=2250244096

    htsjdk.samtools.SAMException: Sequence name '' doesn't match regex: '[0-9A-Za-z!#$%&+./:;?@^_|~-][0-9A-Za-z!#$%&*+./:;=?@^_|~-]*'

    at htsjdk.samtools.SAMSequenceRecord.validateSequenceName(SAMSequenceRecord.java:210)

    at htsjdk.samtools.SAMSequenceRecord.<init>(SAMSequenceRecord.java:93)

    at htsjdk.variant.vcf.VCFContigHeaderLine.getSAMSequenceRecord(VCFContigHeaderLine.java:95)

    at htsjdk.variant.vcf.VCFHeader.getSequenceDictionary(VCFHeader.java:274)

    at org.broadinstitute.hellbender.engine.FeatureDataSource.getSequenceDictionary(FeatureDataSource.java:424)

    at org.broadinstitute.hellbender.engine.FeatureManager.lambda$getAllSequenceDictionaries$6(FeatureManager.java:326)

    at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)

    at java.util.Iterator.forEachRemaining(Iterator.java:116)

    at java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)

    at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)

    at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)

    at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708)

    at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)

    at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499)

    at org.broadinstitute.hellbender.engine.FeatureManager.getAllSequenceDictionaries(FeatureManager.java:328)

    at org.broadinstitute.hellbender.engine.GATKTool.validateSequenceDictionaries(GATKTool.java:739)

    at org.broadinstitute.hellbender.engine.GATKTool.onStartup(GATKTool.java:714)

    at org.broadinstitute.hellbender.engine.ReadWalker.onStartup(ReadWalker.java:50)

    at org.broadinstitute.hellbender.cmdline.CommandLineProgram.runTool(CommandLineProgram.java:138)

    at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMainPostParseArgs(CommandLineProgram.java:192)

    at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:211)

    at org.broadinstitute.hellbender.Main.runCommandLineProgram(Main.java:160)

    at org.broadinstitute.hellbender.Main.mainEntry(Main.java:203)

    at org.broadinstitute.hellbender.Main.main(Main.java:289)

    0
    Comment actions Permalink
  • Avatar
    Genevieve Brandt

    Hi Alex Sanchez, glad it is now working! Please post this issue in a new post since it is unrelated to your first issue, we should be able to look into it.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk