Genome Analysis Toolkit

Variant Discovery in High-Throughput Sequencing Data

GATK process banner

Need Help?

Search our documentation

Community Forum

Hi, How can we help?

Developed in the Data Sciences Platform at the Broad Institute, the toolkit offers a wide variety of tools with a primary focus on variant discovery and genotyping. Its powerful processing engine and high-performance computing features make it capable of taking on projects of any size. Learn more

HaplotypeCaller GENOTYPE_GIVEN_ALLELES doesn't genotype given alleles.

0

5 comments

  • Avatar
    Bhanu Gandham

    Is this plant data? If yes, then try Mutect2 instead of HaplotypeCaller and let me know if that makes any different. Also please upgrade to the latest version of GATK. You are using a very old version.

     

    0
    Comment actions Permalink
  • Avatar
    Mark Derbyshire

    It is plant data, yes. I've moved to a different program now so won't be running Mutect2. Just FYI, I am only using the older version because the newest version doesn't have the option '--genotyping-mode' and runs into the same issue.

    Thank you for your reply.

    0
    Comment actions Permalink
  • Avatar
    David Benjamin

    Mark Derbyshire In the latest several GATK releases there is no -genotyping-mode argument because specifying -alleles _____.vcf alone triggers force calling.

    0
    Comment actions Permalink
  • Avatar
    Mark Derbyshire

    Thank you for your reply David Benjamin. I realise this, and that is how I was running the latest version of GATK. However, whether using --genotyping-mode in an older version or just -alleles in the new version, I found that only a few hundred variants were ever called. It is probably some way in which I am not using the software correctly but I spent a long time testing different options and couldn't solve this issue. If I revisit the problem, I'll update you but for now I'm happy to close the issue as I'm not using GATK (although it is a great program).

    0
    Comment actions Permalink
  • Avatar
    David Benjamin

    Force calling doesn't yield any output if the depth is zero.  Your IGV screenshot shows that this is not the case, but the depths in your VCF are all 1, and I bet that's hiding a lot of sites that had a depth of 0.  What does the read filtering data (at the end of the GATK stdout) show?  

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk