Genome Analysis Toolkit

Variant Discovery in High-Throughput Sequencing Data

GATK process banner

Need Help?

Search our documentation

Community Forum

Hi, How can we help?

Developed in the Data Sciences Platform at the Broad Institute, the toolkit offers a wide variety of tools with a primary focus on variant discovery and genotyping. Its powerful processing engine and high-performance computing features make it capable of taking on projects of any size. Learn more

about Mutect2 usage

0

3 comments

  • Avatar
    David Benjamin

    Sukjung Choi I'm confused because the Mutect2 command says that the normal sample name is normal.bam, but the output VCF header says it is 10001625-TN.replaced.bam.  Could you double-check that the command line you posted is exactly the command you used to generate this output?

    0
    Comment actions Permalink
  • Avatar
    Sukjung Choi

    Thank you for your comment, David

    my command is like that

    /usr/local/lib/gatk-4.1.0.0/gatk --java-options "-Xmx2g" Mutect2 \
    -R /data/Reference/GRCh38/GRCh38.p12.genome.fa \
    -I 10001625-TT.replaced.bam \
    -I 10001625-TN.replaced.bam \
    -tumor 10001625-TT.replaced.bam \
    -normal 10001625-TN.replaced.bam \
    -O 1_somatic_m2.vcf.gz \
    -bamout 2_tumor_normal_m2.bam

    So, I add disable option

    --disable-read-filter MappingQualityAvailableReadFilter \

    Then, I could detect varients.

    Is it all right?

    0
    Comment actions Permalink
  • Avatar
    David Benjamin

    If disabling the mapping quality available read filter is necessary to call variants, then something is wrong with your bam file.  Because mapping artifacts are so common, it is very important for Mutect2 to have access to mapping qualities.  What aligner are you using?  Is there anything in your pipeline that might strip mapping qualities off of reads?

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk