Genome Analysis Toolkit

Variant Discovery in High-Throughput Sequencing Data

GATK process banner

Need Help?

Search our documentation

Community Forum

Hi, How can we help?

Developed in the Data Sciences Platform at the Broad Institute, the toolkit offers a wide variety of tools with a primary focus on variant discovery and genotyping. Its powerful processing engine and high-performance computing features make it capable of taking on projects of any size. Learn more

Recalibration ApplyBQSR crash



  • Avatar
    Gökalp Çelik

    Hi E Ra

    Looks like you are using a reference genome that exceeds the 2^29-1 limit of the bai index therefore you need a CSI index for your bam output. Unfortunately neither GATK nor its base library HTSJDK does support writing CSI indexes so you need to disable bam index creation by using the parameter 

    --CREATE_INDEX false

    You can index your bam file later on using samtools index command with the csi index option on.  

    I hope this helps. 

    Comment actions Permalink
  • Avatar
    E Ra

    Sorry, the code I previously posted is not the right one. The code I used to get this error message is the following one.

    parallel -j 32 "java -XX:ParallelGCThreads=1 \
           -jar gatk-package- ApplyBQSR \
           --reference ${reference_fasta} \
           --input {}.sort.dedup.grp.bam \
           --bqsr-recal-file {}.recal.table \
           --output {}.sort.dedup.grp.realigned.BQSR.bam \
           2>${log_dir}/{}.realign.pass.log" ::: $(ls -1 *.sort.dedup.grp.bam | sed 's/.sort.dedup.grp.bam//')
    Comment actions Permalink
  • Avatar
    E Ra

    The issue seems to be solved when I used the parameter:

    --create-output-bam-index false

    Thank you!

    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk